Скининг MyGUI.

Скиннинг - это создание визуальных элементов отображения для виджетов UI. На этапе скиннинга определяется как будет выглядеть тот или иной элемент.

Чем сложнее виджет тем сложнее его скин. Например, кнопка состоит всего из одного квадратика текстуры, а вот уже полоса прокрутки состоит из подложки, двух кнопок по бокам и кнопки, которая перемещается посередине. Получается что скин - это иерархическое дерево простых элементов, некий шаблон. Сложные элементы могут быть частью еще более сложных элементов. Например, полоса прокрутки является частью списка.

Для упрощения создания скина процесс разбит на две части:

1. Скиннинг - создание простейших элементов на основе текстуры.

2. Макетирование - создание иерархии на основе простейших элементов.

Краткое описание этапов.

Скиннинг.

Этот этап выполняется в редакторе скинов SkinEditor.

На этапе скиннинга выполняются следующие операции:

1. Размечается текстура для различных состояний элемента.

2. Размечаются места растягивания элемента.

3. Размечается место расположения текста, если он нужен элементу.

После скиннинга мы имеем простейший элемент, который можно уже использовать в редакторе макетов и даже непосредственно при создании элементов, но в таком виде элемент не поддерживает свойства и иерархию. Элемент будет иметь состояния и растягиваться но не будет, например, иметь текст. Такой элемент будет похож на простую кнопку без текста.

Макетирование.

Этот этап выполняется в редакторе макетов LayoutEditor.

На этапе макетирования выполняются следующие операции:

1. Выбор шаблона для типа виджета.

2. Создание иерархии элементов для шаблона из простых или более сложных элементов.

3. Указание свойств шаблона.

После макетирования мы имеем полноценный шаблон, который можно указывать в качестве скина элемента.

Скиннинг.

Для начала рассмотрим интерфейс редактора скинов SkinEditor и обозначим основные шаги для создания скина.
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Создание скина состоит из 4 шагов. Каждый шаг выделен в отдельную вкладку.

1. Skin – основные настройки скина.

2. States – состояния скина.

3. Separators – разделители для указания границ растягивания.

4. Regions – регионы полученные в результате разделения.

Skins.

Во вкладке Skins мы работаем со списком всех скинов текущего проекта, расположенного слева. Ниже списка кнопки для создания удаления или переименовывания скина. При выделении скина в списке он становится текущим для редактирования во всех вкладках редактора.

Справа находится панель свойств скина.

1. Координаты скина.

2. Текстура скина.

Из свойства координат скина используется только размер, положение игнорируется, оно используется для визуального контроля положения скина в текстуре.

При выборе текстуры она появляется в средней панели. Так же появляется специальный прямоугольник, который служит для управления положением и размером виджета.

States.

Во вкладке States мы работаем с состояниями скина. Состояние - это вид скина при определенных условиях, например когда над ним курсор.
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Скин поддерживает 8 состояний, но не каждый скин обязан их реализовывать, например у панели только состояние Normal а у обычной кнопки нет состояний в нажатом положении, значит необходимо всего 4 первых состояния. Состояния в приставкой Selected - это состояния когда выджет имеет отмеченное состояние. Например радиокнопка (RadioButton) или флажок (CheckBox) имеют отмеченное состояние.

Описание состояний:

1. Disabled – виджет недоступен, заблокирован.

2. Normal – обычное состояние без воздействия, все виджеты при создании используют это состояние по умолчанию, каждый виджет должен реализовать его, если ему нужно быть видимым.

3. Over – над виджетом висит курсор.

4. Pressed – виджет в нажатом состоянии (нажата кнопка мыши но еще не отпущена), например мышью или горячей клавишей.

5. Selected Disabled — виджет отмечен но заблокирован.

6. Selected Normal – виджет отмечен но нет воздействия.

7. Selected Over – виджет отмечен и над ним курсор.

8. Selected Pressed – виджет отмечен и нажат (нажата кнопка мыши но еще не отпущена), например мышью или горячей клавишей.

При выделении состояния в списке, оно становится текущим для редактирования, на текстуре появляется прямоугольник выделения, который можно двигать по текстуре. Размер менять нельзя, так как у скина один размер на все состояния и этот размер был задан на предыдущем шаге. Над списком находится выпадающий список, в котором можно выбрать предопределенные комбинации состояний. Можно использовать свои комбинации, заблокировав или разблокировав нужные состояния в окне свойств.

Свойства состояния:

1. Position – положение состояния в текстуре.

2. Visible – включение или отключение поддержки состояния.

3. Text colour – цвет текста в текущем состоянии.

4. Text shift – сдвиг текста по вертикали в текущем состоянии.

Свойства Text colour и Text shift используются, если у виджета будет реализован регион для текста. Text shift - это сдвиг текста вниз, с помощью этих свойств можно добиться эффекта, когда текст становится темнее и опускается ниже, например когда виджет в нажатом состоянии.

Separators.

Во вкладке Separators мы работаем с разделителями, которые как бы режут текстуру на части. В зависимости от свойств, части могут быть выравнены по краю или растягиваться, таким образом получается визуальное растягивание виджета без искажений. 
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Самый распространенный вариант - это решетка из 9 регионов используя 4 разделителя.

Угловые 4 региона не растягиваются и приклеены к углам, Между угловыми регионами расположены 4 региона которые привязаны к границе и растягиваются только в направлениях угловых регионов. В центре находится регион который растягивается во всех направлениях.

Пример растягивания 9 регионного скина:
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Сверху исходный скин разрезанный по линиям квадратов а снизу результат растягивания такой разрезки.

Не обязательно использовать 9 регионов, если скин будет растягиваться только, например, горизонтально, то достаточно 2-х вертикальных разделителей, т.е. 3-х регионов. Если виджет не будет растягиваться, или его растягивание должно быть равномерным по всей площади скина то возможно обойтись одним регионом совсем без разделителей. В случае, когда нет разделителей, считается что весь скин является центральной частью и весь будет растягиваться.

Сверху над списком разделителей есть выпадающий список с некоторыми вариантами наборов разделителей. Можно использовать свой набор используя свойство Visible разделителя для включения или отключения.

Свойства разделителей:

1. Offset – смещение разделителя от границы.

2. Visible – включение или отключение текущего разделителя.

Regions.

Во вкладке Regions можно посмотреть результат разбиения скина на регионы разделителями, а так же добавить регион для текста.
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Слева находится список всех регионов, так же в списке есть регион с именем Text. Этот регион по умолчанию выключен, включить его можно на панели свойств с помощью свойства - Visible.

Все регионы неподвижны, так как создаются с помощью разделителей, исключение - регион текста, его можно двигать и менять размер, подбирая наилучшее положение.

Свойства регионов:

1. Coords – положение региона, доступно только для текста.

2. Visible – видимость региона, можно отключать и включать регионы.

3. Enabled – доступность региона, если какой-либо разделитель отсутствует то все регионы которые от него зависят становятся недоступными.

4. Align – выравнивание региона.

5. Region type – тип региона.

Region type - это тип региона. Тип определяет поведение при растягивании и/или другие свойства региона.

Доступные типы регионов:

1. SubSkin – тип региона по умолчанию, присваивается всем регионам которые появляются благодаря разделителям. Является частью простой текстуры и растягивается по всему доступному ему пространству.

2. SimpleText – тип региона для текста, не содержит текстуры. Текст располагается внутри этого региона и не выходит за его границы.

3. EditText – регион для редактируемого текста, поддерживается только в спец виджетах, например EditBox.

4. TileRect – тип региона, который не растягивается, а копирует часть текстуры по всей доступной поверхности.

5. TileRect Hor — то же что и TileRect, только копирует часть текстуры по горизонтали, а по вертикали просто растягивается.

6. TileRect Ver – то же что и TileRect, только копирует часть текстуры по вертикали, а по горизонтали просто растягивается.

Пример растягивания скина, у которого центральная часть имеет тип TileRect:
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Пример растягивания скина, у которого центральная часть имеет тип TileRect Ver:
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Сохранение.

После завершения создания скина его необходимо сохранить в файл. После этого он станет доступным для редактора макетов.

На этом этап создания базовых скинов можно считать завершенным, и переходить в редактор макетов для завершения создания полноценных скинов.

Макетирование.

Макетирование это процесс создания макета или шаблона скина в редакторе макетов LayoutEditor.

Окно редактора состоит из рабочей области, меню и панели свойств. Меню свойств имеет следующие страницы:

1. Properties – страница свойств текущего виджета, если такой имеется.

2. Widgets – панель с палитрой виджетов для создания.

3. Project – текущий проект если такой имеется.
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Интерфейс редактора макетов:
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Для начала работы необходимо подключить папки с ресурсами через окно настроек.

Создаем проект, через меню Project->Create project … .

После создания проекта его имя отобразится в списке проекта в панели Project.

В список проекта можно добавлять шаблоны, удалять их или переименовывать.

Процесс создания шаблоны состоит из двух шагов:

1. Создания обычного макета, но с флагом Template у главного виджета.

2. Добавления макета в проект через меню Project -> Add layout to project .

После добавление макета его имя отобразится в списке проекта.

После сохранения проекта его можно загружать в программе и использовать имена шаблонов как скины для виджетов.

Создание скина с нуля.

Теперь попробуем создать скин с нуля, от самого начала до самого конца используя редактор скинов и редактор макетов. Мы будем создавать скин окна. У окна будет заголовок и кнопка закрытия.

Открываем любой доступный редактор картинок и рисуем наше окно. Так же нам необходимо изобразить кнопку закрытия в 3 состояних (Disable нам не пригодится).

Получаем вот такое изображение :
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Вот так оно выглядит с фоном :
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Сохраняем картинку как ExampleSkin.png

Создаем папку ExampleSkin в которой будут хранится все наши ресурсы. Копируем в эту папку нашу картинку ExampleSkin.png

Создание скина в редакторе скинов.

Настройка редактора скинов.

Открываем редактор скинов и добавляем нашу папку с ресурсами в папки редактора.

Для этого открываем настройки через меню File->Settings

Выбираем вкладку Folders

Жмем кнопку Add и указываем нашу папку ExampleSkin через окно выбора папок, в моем примере это путь D:\ExampleSkin
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Жмем Ok и перезагружаем редактор (Закрываем его и снова открываем).

Теперь сохраним наш пустой проект чтобы случайно его не потерять. Для этого выберам в меню File->Save as …

Выбираем нашу папку ExampleSkin и имя файла ExampleSkin.xml и жмем Save.

Создание скина окна.

Приступаем к созданию первого скина, скина окна. Для этого жмем на кнопку Create которая находится под списком:
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После этого у нас появится первый скин в списке с дефолтным названием, выделим его и нажмем кнопку Rename для того чтобы указать ему нужное нам имя.
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Назовем наш первый скин ExampleWindowSkin.
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После этого выбираем текстуру для нашего скина, для этого выделяем наш скин в списке скинов и в панели свойств выбираем нашу текстуру либо через выпадающий список либо через браузер текстур.
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После выбора текстуры она отобразится в средней панели.
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Панель поддерживает масштабирование колесиком мыши или через меню Scale.

Передвигать текстуру можно полосами прокрутки по краям панели либо зажав и удерживая правую клавишу мыши.

Размер позиции и размера скина указывается зеленым прямоугольником (селектором) на текстуре. Селектор можно растягивать за квадратики по его краям. Передвигать селектор можно кликнув на нем мышью или с помощью клавиш вверх, вниз, влево, вправо. Если зажать Control то будет менять не положение селектора а размер. Положение и размер можно менять и вручную, для этого есть поле Coords в панели свойств скина. 

В панели текстуры можно менять цвет и прозрачность фона, это удобно для полупрозрачных скинов. Настройка цветов происходит через меню Colours.

Для начала изменим цвет фона текстуры чтобы нам было видно где кончается тень у нашего полупрозрачного скина окна.

Открываем палитру через меню Colours->Background colour …

И выбираем нужный нам цвет.
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Теперь передвигая и растягивая селектор выбираем размер нашего скина окна. Для более аккуратного движения можно использовать клавиши стрелок, а для изменения размеров — их же с зажатой клавишей Ctrl.

[image: image20.png]File  Colours  Scale
skins  ('States" ~Separators
Normal only.

Disabled

Normal

over

Pressed

Selected Disabled
Selected Normal
Selected Over
Selected Pressed

Regions

Position

Visible

Text colour

Text shift




У меня получился размер 208 на 208 пикселей.

Переходим во вторую вкладку States.
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Наше окно будет иметь только одно состояние Normal для этого либо через выпадающий списко выбираем «Normal only» или вручную отключаем все состояния кроме Normal с помощью свойства Visible на панели свойств.

Теперь нам необходимо указать смещение состояния внутри текстуры, для этого выделаем состояние Normal в списке и двигаем селектор в нужную нам позицию.
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У меня получилось смещение 7 по горизонтали и 7 по вертикали.

Переходим в третью вкладку Separators.
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Наше окно будет растягиваться во все стороны поэтому нам необходимо выбрать режим с 9 регионами. Для этого выберем в выпадающем списке «9 regions grid» или вручную включим все 4 разделителя с помощью свойства Visible на панели свойств.
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В данный момент все наши разделители имеют смещение 1 и расположены в краях текстуры. Необходимо выделять разделители в списке и двигать их с помощью мыши в те места в которых нам нужен разрез.

Вот пример моего разделения скина:
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У меня получились смещения 75 40 40 40.

Переходим в 4 вкладку Regions.
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Слева видим список регионов, видимые регионы отображаются белым цветом, недоступные регионы отображаются серым цветом. Мы можем включать и выключать регионы, для этого его необходимо выделить в списке и изменить параметр Visible в панели свойств.

[image: image27.png]



Наш скин окна готов, сохраним проект File->Save.

Теперь можно проверить скин в действии, для этого включаем тест через меню File->Test.

В режиме теста можно растягивать окно с заголовком Test и будет растягиваться наш скин расположенный внутри него.
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Нажмите Esc для выхода из режима теста.

Создание скина кнопки закрытия окна.

Итак, теперь приступим к созданию кнопки для закрытия окна. Создаем второй скин и называем его ExampleWindowButtonSkin. Выбираем нашу текстуру если она не выбралась автоматически.
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Теперь ставим селектор в нужное нам положение.

У меня получилось 224 9 26 26.
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Переходим во вкладку States.

Нам необходимо 3 состояния, Normal, Over и Pressed. Для этого выделяем нужное нам состояние в списке, меняем его свойство Visible на True и двигаем селектор в нужное нам положение.
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Переходим во вкладку Separators.

Наша кнопка не предназначена для растягивания, поэтому ей не нужны разделители. Выбираем в выпадающем списке «One scale region» при этом все разделители станут серыми. И наша кнопка будет состоять из одного региона который будет растягиваться во все доступное пространство скина.
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Переходим во вкладку Regions.

Сейчас у нас включен только один регион Center. Для отображения крестика на кнопке мы будем использовать обычный текст, поэтому нам необходимо добавить второй регион с текстом. Выделите регион с именем Text, измените его свойство Visible на True в панели свойств. Теперь измените его размер, через свойство или двигая мышью, чтобы он был внутри кнопки.
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Теперь его можно протестировать - заходим в режим теста.

Видим нашу кнопку с тестовым текстом внутри, если он помещается туда.
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При растягивании окна наша кнопка будет увеличиваться с искажениями, так как мы выбрали один регион, но нам это не важно так как наша кнопка не предназначена для растягивания.
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На кнопку можно наводить мышь и кликать по ней, при этом она должна менять свое состояние.

Теперь добавим один эффект, при нажатии на кнопку мы будем сдвигать текст вниз на один пиксель, это придаст состоянию нажатия более красивый вид.

Нажмите Esc для выхода из теста.

Перейдем во вкладку States.

Выберем состояние Pressed.

В свойстве Text shift введем число 1.

[image: image37.png]File  Project Edit Widgets Colours Scale

Properties | Widgets  Project

Settings
General  Widgets  Folders Resources  Update

Path to resources (restart required)





Зайдем в режим теста и снова покликаем по кнопке. Теперь в нажатом состоянии текст сдвигается вниз.

Нажмите Esc для выхода из режима теста.

Наш скин кнопки готов, сохраним проект File->Save.

На этом работа в редакторе скинов закончена, наши скины сохранены в файл ExampleSkin.xml .

Создание шаблона в редакторе макетов.

Настройка редактора макетов.

Открываем LayoutEditor и заходим в настройки File->Settings.

Переходим во вкладку Folders и добавляем нашу папку со скином в список папок.
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Теперь добавим наш скин в список загружаемых ресурсов. Переходим во вкладку Resources и добавляем имя нашего скина ExampleSkin.xml . Здесь нужно указывать именно имя файла без пути. Файлы ресурсов ищутся в тех путях, которые мы указали в предыдущей вкладке.
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Жмем на кнопку Ok и перезагружаем редактор (для этого закрываем его и открываем снова).

Создание шаблона окна.

Для начала нам необходимо создать проект для наших шаблонов. Выбираем в меню Project->Create project …

В окне создания проекта выбираем нашу папку ExampleSkin и вводим имя нашего проекта ExampleTemplate.xml .
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Жмем кнопку Create.

Теперь на закладке Project мы видим имя нашего проекта.
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Теперь сразу добавим наш проект в список загружаемых ресурсов. Для этого зайдем в настройки File->Settings и перейдем во вкладку Resources.

Жмем кнопку Add и вписываем имя нашего проекта ExampleTemplate.xml
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Жмем Ok и перезагружаем редактор.

Теперь переходим непосредственно к созданию шаблона окна. Переключаемся во вкладку Widgets, кликаем на виджете с именем PanelEmpty, после этого кликаем в рабочую область и не отпуская мыши растягиваем произвольный размер.
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Мы создали простейший виджет с невидимой текстурой, теперь нам необходимо поменять его скин на ExampleWindowSkin и сделать ему размер совпадающий с нашим скином.

Выделяем наш виджет и переходим во вкладку Properties.

В выпадающем списке свойства Skin ищем и выбираем скин ExampleWindowSkin.
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Теперь меняем размер нашего шаблона на размер скина, размер скина можно посмотреть в подсказке если навести курсор на имя скина в свойстве Skin.

В моем случае это 208 на 208.

[image: image45.png]File  Project Edit Widgets Colours Scale

Properties  Widgets (“Project
ExampleTemplate.xml





Для того чтобы макет был шаблоном необходимо выбрать еще несколько настроек и добавить его в проект.

В свойстве Name нужно указать имя Root, которое зарезервировано для главного окна шаблонов.

В свойстве Template нужно выбрать true.

В свойстве Type нужно выбрать Window, так как мы создаем шаблон для окна.
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Теперь добавляем наш шаблон в проект. Выбираем в меню Project->Add layout to project.

После этого в списке проекта должен появится один шаблон unnamed.
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Теперь переименуем наш шаблон.

Выделим в списке этот шаблон, выберем в меню Project->Rename selected layout in project …  и введем имя ExampleWindowTemplate и нажмем Ok.
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Наше шаблон уже можно использовать как окно, но у него нет заголовка и клиентской зоны, поэтому его нельзя будет перетаскивать а дочерние виджеты будут принадлежать всему окну и выходить на прозрачную декоративную зону.

Сначала добавим заголовок.

Перейдем на вкладку Widgets, выберем скин TextBox и растянем его в области нашего заголовка.
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Теперь перейдем на панель свойств и выберем нужные нам свойства для заголовка.

Сначала выставим основные свойства Main properties:

Свойство Align нужно выставить в HStretch Top — это значит что наш заголовок будет растягиваться вместе с окном по горизонтали и будет всегда висеть вверху.

Свойство Name нужно выставить в Caption — по этому имени окно ищет заголовок в шаблоне.
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Теперь выставим свойства текстового поля TextBox properties:

Свойство FontName выставим в Default.

Свойство TextAlign выставим в Center, чтобы текст заголовка был в середине заголовка.
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Теперь проверим наш первый вариант окна.

Сохраним шаблон File->Save.

Очистим наше рабочее пространство File->Clear.

Перезагрузим все ресурсы File->Update resources.

Выберем на панели Widgets шаблон стандартного окна, например WindowC и создадим его, кликнув в рабочую область и не отпуская мыши растянем до любого нужного размера.
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Перейдем во вкладку Properties и в свойстве Skin выберем наш шаблон ExampleWindowTemplate. Не перепутайте со скином ExampleWindowSkin.
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После смены шаблона мы увидим наше знакомое окно.
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Поменяем свойство Caption на «My first skin».
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Теперь наше окно можно протестировать.

Выберем в меню File->Test.
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Наше окно отображает заголовок и его можно перетаскивать мышью.

Продолжим, для начала очистим рабочую область File->Clear. Редактор спросит, хотим ли мы сохранить изменения, жмем No так как это был тест нашего шаблона.

Переходим во вкладку Project и двойным щелчком выбираем наш шаблон. Он должен появится в рабочей области.
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Теперь поменяем цвет нашего заголовка, так как белый цвет сливается с цветом нашего скина.

Выделим заголовок и в свойстве TextColour выбирем нужный нам цвет.

Можно поиграться с параметрами:

Свойство TextColour отвечает за цвет текста.

Свойство TextShadow отвечает за отображение тени текста.

Свойство TextShadowColour отвечает за цвет тени текста.

Для удобства, временно, можно в свойстве Caption написать произвольный текст чтобы сразу видеть изменения свойств текста, но необходимо его потом стереть, иначе он попадет в шаблон и будет по умолчанию отображаться.

У меня получился черный текст и белая тень, текст как будто бы проваливается в окно.
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Теперь создадим клиентскую зону, это зона где будут содержаться дети окна, при выходе за эту зону они будут обрезаться и не будут залезать, например, на заголовок.

В панели Widgets выделим скин PanelEmpty и растянем его в нужном нам месте.

[image: image59.png]File  Project Edit Widgets Colours Scale

Properties Widgets  Project
Default  Other  Plugin

CheckBox
RadioButton Buttonimage
Canvas ComboBox
EditBox EditBoxStretch
EditBoxEmpty  WordWrapEmpty
ItemBox ListBox
MenuBar MultiListBox
PopupMenu ProgressBar
ProgressBarfill ScrollBarV
ScrollBarH SliderV
SliderH Scrollview
ScrollViewEmpty Rotatingskin
ImageBox TextBox
TabControl PanelEmpty
Window WindowC.
WindowCX WindowCs

WindowCSX

Popup mode





Не стоит переживать о том что PanelEmpty и другие прозрачные скины на самом деле не прозрачные, это сделано для удобства в редакторе, при создании в обычном режиме эти скины будут невидны.

Перейдем в панель Properties и изменим несколько свойств нашей клиентской зоны.

В свойстве Align выберем Stretch так как наша зона будет растягиваться вместе с окном всегда.

В свойстве Name выберем Client - это зарезервированное имя, по которому окно ищет свою клиентскую зону в шаблоне.
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Протестируем наш шаблон, для этого сохраним его File->Save, очистим рабочую область File->Clear и перезагрузим все ресурсы File->Update resources.

Создадим виджет WindowC и поменяем ему шаблон на наш ExampleWindowTemplate.

В свойстве Caption напишем произвольный текст.

Теперь проверим нашу клиентскую зону, для этого возьмем и создадим внутри окна любой виджет, например кнопку и подвигаем ее внутри окна. Кнопка должна обрезаться по нашей клиентской зоне.
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Как видим, несмотря на то что кнопка имеет размеры больше, чем клиентская зона, она обрезается по ней.

Очистим рабочую область и снова перейдем в редактирование нашего шаблона, кликнув двойным щелчком по нему в списке проекта.

Теперь мы добавим специальную невидимую область в правый нижний угол нашего шаблона, за которую мы будем растягивать окно.

Во вкладке Widgets выберем PanelEmpty и создадим ребенка в правом нижнем углу окна.
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Необходимо чтобы этот скин был ребенком окна а не, например, клиентской зоны, проверить это можно в меню Widgets.
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Видно что у нашего окна, 3 ребенка, значит мы не промахнулись.

Теперь перейдем во вкладку Properties и изменим некоторые свойства.

В свойстве Align нужно выбрать Right Bottom так как наш растягиватель будет всегда в правом нижнем углу.

В свойстве Name выберем ResizeRightBottom это зарезервированое имя по которому окно ищет растягиватель в шаблоне.
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Теперь протестируем наш шаблон.

Сохраним File->Save, очистим File->Clear, перегрузим ресурсы File->Update resources.

Создадим окно WindowC и поменяем скин на ExampleWindowTemplate.

Запустим тест File->Test и попробуем растянуть окно мышью за правый нижний угол. Окно растягивается.
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Наше окно может растягиваться до отрицательных или очень больших размеров и курсор мыши не меняется при наведении на растягиватель, давайте поправим эти параметры шаблона.

Выйдем из режима теста, очистим рабочую область и снова перейдем в режим редактирования шаблона.

Выделим наш растягиватель и в свойстве Pointer укажем size_left.

[image: image66.png]File  Project Edit Widgets Colours Scale

Properties | Widgets  Project
TextBox properties
Caption

FontHeight
FontName
Textalign
TextColour
Textshadow
TextshadowColour
Window,oronerties
#AlltoAlpha
MaxSize 400 400
Minsize 150 150 “

——)

Movable
Shap

User data

Key Value

Add Delete





Это свойство можно проверить в режиме создания шаблона, просто зайдите в тест File->Test и наведите мышь на наш растягиватель, курсор должен меняться на стрелочки растягивания.

Теперь выделим наш главный скин шаблона, который имеет имя Root, можно выделить кликая мышью, а можно выделить через меню Widgets, кликнув на виджете с именем Root.
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Теперь перейдем в панель свойств и выставим максимальный и минимальный размер нашего окна при растягивании в свойствах MaxSize и MinSize.

Я выставил 400 на 400 и 150 на 150.
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Тестируем наш шаблон.

File->Save, File->Clear, File->Update resources.

Создаем тестовое окно WindowC и меняем скин на ExampleWindowTemplate.

File->Test.

Теперь при тестировании можно заметить что окно не выходит за границы этих размеров.
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Создание шаблона кнопки.

Теперь создадим кнопку для нашего окна. Для начала очистим рабочую область File->Clear. Теперь как и в первом случае создадим заготовку для нашего шаблона из скина PanelEmpty.
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Теперь изменим свойства нашей заготовки.

В свойстве Name укажем Root.

В свойстве Skin укажем наш скин ExampleWindowButtonSkin.

В свойстве Position укажем исходный размер скина, у меня это 26 на 26.

В свойстве Template выбираем true.

В свойстве Type выбираем Button.
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В свойстве FontName выберем Default.

В свойстве TextAlign выберем Center.

В свойстве Caption поставим букву X так как мы договорились что крестик будем отображать текстом.

Крестик на нашем шаблоне не будет отображаться, так как это на самом деле Widget а не Button, а у Widget нет свойств текста. Но как только мы создадим кнопку с нашим шаблоном, текст сразу появится.
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Теперь добавим наш шаблон в проект.

Выбираем в меню Project->Add layout to project.

После этого наш шаблон появится в списке проекта под именем unnamed.

Переименуем шаблон, выбираем в меню Project->Rename selected layout in project … и вписываем имя шаблона ExampleWindowButtonTemplate.

Сохраняем проект File->Save.
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Наш шаблон кнопки готов, теперь протестируем его.

File->Save, File->Clear, File->Update resources.

Создаем кнопку Button и меняем у нее свойство Skin на ExampleWindowButtonTemplate.

Для удобства меняем размер кнопки на размер нашего шаблона, у меня это 26 на 26.
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Как видим появился и наш крестик. Заходим в тестирование File->Test и кликаем по нашей кнопке.

Создание шаблона окна с кнопкой.

Открываем наш шаблон окна двойным кликом в списке проекта.

Уменьшим размер заголовка Caption чтобы поместилась наша кнопка.

Переходим в панель Widgets и создаем обычную кнопку справа от заголовка.
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Нужно проверить что кнопка является ребенком главного окна шаблона, это можно проверить через меню Widgets. У главного окна должно быть 4 ребенка.
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Теперь изменим некоторые свойства кнопки.

В свойстве Align необходимо указать Right Top так как наша кнопка будет привязана к правому углу.

В свойстве Name необходимо указать Button, это зарезервированное имя по которому окно ищет кнопки в шаблоне.

В свойстве Skin выбираем наш шаблон ExampleWindowButtonTemplate.

В свойстве размера указываем размер нашего шаблона, у меня 26 на 26.
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Теперь необходимо указать какое событие генерирует эта кнопка для окна.

Для этого в User data необходимо указать ключ Event и значение close и нажать Add.

После этого ключ и значение должны появится в списке.
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Теперь протестируем наш шаблон.

File->Save, File->Clear, File->Update resources.

Создаем виджет WindowC и меняем скин на ExampleWindowTemplate.

Меняем свойство Caption на «My window template»

Запускаем тестирование File->Test.
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Мы закончили создание шаблона для окна, теперь его можно использовать в приложении.

Сохраним наш тестовый макет. File->Save as …

Выберем имя ExampleWindow.layout
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Добавление шаблона в палитру редактора.

Неудобно каждый раз создавать стандартный скин и менять его на нужный. Гораздо удобнее иметь нужные скины в палитре и создавать их в один клик.

Создайте файл с описанием наших шаблонов:

<?xml version="1.0" encoding="UTF-8"?>

<MyGUI type="Widgets">


<Widget name="Button">



<Property key="Skin" value="ExampleWindowButtonTemplate" group="Example"/>


</Widget>


<Widget name="Window">



<Property key="Skin" value="ExampleWindowTemplate" group="Example"/>


</Widget>

</MyGUI>

Формат этого файла соответствует формату файла Widgets.xml который находится в папке ресурсов редактора макетов LayoutEditor.

Сохраните файл под именем ExampleWidgets.xml в папке ExampleSkin и укажите этот файл для загрузки в настройках редактора.
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Теперь в палитре виджетов появилась закладка с именем Example а в ней наши шаблоны.


Теперь шаблоном можно пользоваться.

